Changer le from "nagios" dans EON

samww
Messages : 7
Enregistré le : 15 mai 2012, 11:33

Changer le from "nagios" dans EON

Message par samww » 29 novembre 2012, 18:08

Bonjour,

Je désespère pour changer l’émetteur du mail "nagios" par le nom du serveur EON.

J'arrive bien à changer l'adresse expéditrice du mail, mais le from reste "nagios", la variable $myhostname dans le main.cf est bien modifier, j'ai essayé également de rajouter l'option -a "FROM..." dans la commande de notification par mail...

Can you help me please ?? :)

Avatar du membre
Seb
Messages : 3556
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Changer le from "nagios" dans EON

Message par Seb » 29 novembre 2012, 20:16

En changeant les commandes "notify by email host" (et service) ça doit fonctionner.
Tu as bien mis les "" autour de "FROM: nomexpéditeur" ???
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Avatar du membre
Guiona
Messages : 762
Enregistré le : 18 janvier 2012, 16:36
Localisation : Toulouse
Contact :

Re: Changer le from "nagios" dans EON

Message par Guiona » 30 novembre 2012, 10:15

Juste le display name c'est ça?
La connaissance appartient à ceux qui la partagent.

samww
Messages : 7
Enregistré le : 15 mai 2012, 11:33

Re: Changer le from "nagios" dans EON

Message par samww » 30 novembre 2012, 10:50

Merci du retour,

Ma syntaxe est-elle OK ?? :

/usr/bin/printf "%b" "***** XXXXXXXXXXXXXXXX *****\\n\\nNotification Type: $NOTIFICATIONTYPE$\\nHost: $HOSTNAME$\\nState: $HOSTSTATE$\\nAddress: $HOSTADDRESS$\\nInfo: $HOSTOUTPUT$\\n\\nDate/Time: $LONGDATETIME$\\n" | /bin/mail -a "FROM:Expediteur" -s "Alerte pour : $HOSTNAME$!, type $HOSTSTATE$" $CONTACTEMAIL$

car cela ne fonctionne pas ! le from est toujours nagios dans Outlook...

lorsque j'essaie de tester l'envoi de mail simple l'option -a n'est pas reconnu...

echo "Un message de test" | mail -a "FROM:Expediteur" -s "sujet de test" samww@mondomaine.fr
mail: invalid option -- a
Usage: mail [-iInv] [-s subject] [-c cc-addr] [-b bcc-addr] to-addr ...
[-- sendmail-options ...]
mail [-iInNv] -f [name]
mail [-iInNv] [-u user]

je dois zapper quelque chose...!

samww
Messages : 7
Enregistré le : 15 mai 2012, 11:33

Re: Changer le from "nagios" dans EON

Message par samww » 30 novembre 2012, 10:51

Guiona a écrit :Juste le display name c'est ça?
Oui juste le display name !

Avatar du membre
Guiona
Messages : 762
Enregistré le : 18 janvier 2012, 16:36
Localisation : Toulouse
Contact :

Re: Changer le from "nagios" dans EON

Message par Guiona » 30 novembre 2012, 11:47

Editer le fichier "/etc/passwd" et changer le display name (5ème champs):

Code : Tout sélectionner

nagios:x:500:500:nagios:/home/nagios:/bin/bash
devient

Code : Tout sélectionner

nagios:x:500:500:Mon display Name:/home/nagios:/bin/bash
La connaissance appartient à ceux qui la partagent.

Avatar du membre
Seb
Messages : 3556
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Changer le from "nagios" dans EON

Message par Seb » 30 novembre 2012, 12:58

"FROM:Expediteur"
Une "espace" doit être présent entre les ":" et "expéditeur"
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

samww
Messages : 7
Enregistré le : 15 mai 2012, 11:33

Re: Changer le from "nagios" dans EON

Message par samww » 30 novembre 2012, 16:39

Guiona a écrit :Editer le fichier "/etc/passwd" et changer le display name (5ème champs):

Code : Tout sélectionner

nagios:x:500:500:nagios:/home/nagios:/bin/bash
devient

Code : Tout sélectionner

nagios:x:500:500:Mon display Name:/home/nagios:/bin/bash

Merci, c'était bien la mon problème...: Résolu...!! (pourtant je me doutais bien que c'était le $USER Linux....!!! grrrr...!!)

--------------------RESOLU------------------------

Avatar du membre
Guiona
Messages : 762
Enregistré le : 18 janvier 2012, 16:36
Localisation : Toulouse
Contact :

Re: Changer le from "nagios" dans EON

Message par Guiona » 01 décembre 2012, 09:33

Merci du retour!
La connaissance appartient à ceux qui la partagent.

Deschanel
Messages : 8
Enregistré le : 05 août 2015, 20:26

Re: Changer le from "nagios" dans EON

Message par Deschanel » 26 août 2015, 20:39

j'ai eu le meme probleme et apres modification du fichier c'est OK!!!! :)

Répondre