[résolu]nagios et thrunk ne démmarrent plus

Répondre
palouf34
Messages : 96
Enregistré le : 13 août 2015, 10:59
Localisation : saint-junien

[résolu]nagios et thrunk ne démmarrent plus

Message par palouf34 » 24 mars 2016, 15:20

Bonjour,

voici un topo de mon probléme.

j'ai voulus modifié une surveillance et elle ne n’appliquais pas ( changement d'un argument).

après avoir galéré je me suis rendu compte que le disque système était plein... j'ai viré quelque vielle sauvegarde. ensuite reboot sur serveur.

Permier problème aprés le premier reboot, thrunk ne se lance plus. voici le message d'erreur:

Code : Tout sélectionner

No Backend available
None of the configured Backends could be reached, please have a look at the logfile for detailed information and make sure the core is up and running.

Details:
EyesOfNetwork: ERROR: failed to open socket /srv/eyesofnetwork/nagios/var/log/rw/live: No such file or directory (/srv/eyesofnetwork/nagios/var/log/rw/live)

j'ai tenté de créer le fichier live mais sans succés.

pensant à une erreur dans nagios j'ai tenté d'appliquer la configuration mais la paf le chien, nagios ne veux plus exporté et m'indique les messages suivant:

Code : Tout sélectionner

Starting nagios:CONFIG ERROR!  Start aborted.  Check your Nagios configuration.
alors que la commande :

Code : Tout sélectionner

/srv/eyesofnetwork/nagios/bin/nagios -v /tmp/lilac-export-1/nagios.cfg

renvoie les message suivant :

Code : Tout sélectionner

        Checked 171 hosts.
Checking host groups...
        Checked 17 host groups.
Checking service groups...
        Checked 5 service groups.
Checking contacts...
        Checked 7 contacts.
Checking contact groups...
        Checked 3 contact groups.
Checking service escalations...
        Checked 0 service escalations.
Checking service dependencies...
        Checked 0 service dependencies.
Checking host escalations...
        Checked 18 host escalations.
Checking host dependencies...
        Checked 0 host dependencies.
Checking commands...
        Checked 163 commands.
Checking time periods...
        Checked 3 time periods.
Checking for circular paths between hosts...
Checking for circular host and service dependencies...
Checking global event handlers...
Checking obsessive compulsive processor commands...
Checking misc settings...

Total Warnings: 1134
Total Errors:   0

j'ai tenté de restauré nagios de la sauvegarde de cette nuit mais rien a faire.

Avez vous une idée ??

Merci pour votre aide bien précieuse.

cordialement
Modifié en dernier par palouf34 le 24 mars 2016, 15:52, modifié 1 fois.

palouf34
Messages : 96
Enregistré le : 13 août 2015, 10:59
Localisation : saint-junien

Re: nagios et thrunk ne démmarrent plus

Message par palouf34 » 24 mars 2016, 15:37

oups je viens de voir que je me suis tromper de lieu.. merci à un admins de le déplacer...

palouf34
Messages : 96
Enregistré le : 13 août 2015, 10:59
Localisation : saint-junien

Re: nagios et thrunk ne démmarrent plus

Message par palouf34 » 24 mars 2016, 15:51

je me réponds a moi même,

le problème venait du fichier de conf dans

Code : Tout sélectionner

/etc/init.d/nagios
il ne pointait plus vers les bon dossiers..

problème de mise à jour système peut-être.

Cordialement.

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: [résolu]nagios et thrunk ne démmarrent plus

Message par Seb » 24 mars 2016, 16:48

Désolé pour le manque de réactivité, pas pu accéder avant au forum ...
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

boba
Messages : 8
Enregistré le : 13 juillet 2016, 11:29

Re: [résolu]nagios et thrunk ne démmarrent plus

Message par boba » 07 avril 2017, 13:34

Bonjour l'equipe,
j'ai le probleme suivant:

No Backend available
None of the configured Backends could be reached, please have a look at the logfile for detailed information and make sure the core is up and running.

Details:
EyesOfNetwork: ERROR: failed to open socket /srv/eyesofnetwork/nagios/var/log/rw/live: No such file or directory (/srv/eyesofnetwork/nagios/var/log/rw/live)

J'utilise la version 5.0
J'ai cherche partout dans le forum mais j'y arrive pas. Quelqu'un peux m'aider c'est mon serveur de supervision qui est en prod.

merci

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: [résolu]nagios et thrunk ne démmarrent plus

Message par Seb » 07 avril 2017, 22:21

Tout d'abord regarde si ton disque n'est pas full.
Tente ensuite un restart du service nagios!
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

boba
Messages : 8
Enregistré le : 13 juillet 2016, 11:29

Re: [résolu]nagios et thrunk ne démmarrent plus

Message par boba » 10 avril 2017, 10:38

Bonjour Seb,

Merci pour ta reaction.
J'ai check le disque n'est pas Full. J;'ai redemarrer Nagios mais RAS.

merci

Répondre