[résolu]check qui ne répond pas en mode web

palouf34
Messages : 96
Enregistré le : 13 août 2015, 10:59
Localisation : saint-junien

[résolu]check qui ne répond pas en mode web

Message par palouf34 » 07 juin 2017, 09:52

Bonjour,

dans le cadre d'une surveillance, je suis obligé de passer par une seconde machine pour que ma commande soit exécuter.

ce check ne fait qu'un simple ping via un script powershell car depuis EON le resultat ne permet pas d'avoir la bonne réponse.

voici le scipt pour mon check_ping

Code : Tout sélectionner

# ====================================================================
# Ping a list of targets through NRPE
# Author: Mathieu Chateau - LOTP
# mail: mathieu.chateau@lotp.fr
# version 0.1
# ====================================================================

#
# Require Set-ExecutionPolicy RemoteSigned.. or sign this script with your PKI 
#

# ============================================================
#
#  Do not change anything behind that line!
#
param 
(
    [string]$targets,
    [int]$maxWarn = 1,
    [int]$maxError = 5
)
	    
    $output=""
    $exitcode=2
    $countOK=0
    $countKO=0
    $targetsArray=@()
    $targetsArray=$targets -split(' ')
    Remove-Job -Name * -Confirm:$false -Force
    foreach($t in $targetsArray)
    {
Start-Job -Name $t -ArgumentList $t -ScriptBlock {param($t);if(Test-Connection -ComputerName $t  -Count 2 -Quiet -ErrorAction SilentlyContinue){return $true}else{return $false}} |Out-Null
}
while(Get-Job -State Running)
{
    Start-Sleep -Milliseconds 500
    }
    foreach ($job in Get-Job)
    {
    $temp=Receive-Job -Name $job.Name
    if($temp)
    {
	$countOK++
    }
    else
    {
	$countKO++
        $output+=$job.Name+" - "
    }
    }
if ($countKO -gt $maxError)
{
    $state="CRITICAL"
$exitcode=2
}
elseif ($countKO -gt $maxWarn)
{
    $state="WARNING"
    $exitcode=1
}
else
{
    $state="OK"
    $exitcode=0
}

$output=$state+":"+$countOK+" online"+" - "+$countKO+" offline - "+$output
$output+='|'
$output+="online="+$countOK+";"+$maxWarn+";"+$maxError+";"+" "
$output+="offline="+$countKO+";"+$maxWarn+";"+$maxError+";"
Write-Host $output
exit $exitcode

avec l'utilisateur nagios mon check passe sans problméme

Code : Tout sélectionner

 [nagios@srvEON plugins]./check_nrpe -H [i]ip serveur de rebond[/i] -c check_ping -a [i]ip a checker[/i]
OK:1 online - 0 offline -|online=1;1;5; offline=0;1;5;
mais depuis l'interface web j'obtiens invariablement la réponse

Code : Tout sélectionner

(Return code of 127 is out of bounds - plugin may be missing)
cela fait un moment que je tourne en rond concernant cette fichu surveillance.
Modifié en dernier par palouf34 le 20 juin 2017, 09:00, modifié 1 fois.

Avatar du membre
Seb
Messages : 3556
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: check qui ne répond pas en mode web

Message par Seb » 08 juin 2017, 09:20

Quand tu vas dans la vue de l'équipement concerné, en bas, il effectue quelle commande?
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

palouf34
Messages : 96
Enregistré le : 13 août 2015, 10:59
Localisation : saint-junien

Re: check qui ne répond pas en mode web

Message par palouf34 » 08 juin 2017, 14:04

heu la je comprends plus car la commande dans le web n'est plus la même....

il exécute la commande

Code : Tout sélectionner

$USER1$/check_ping -H ip_destination -w 5000.0,80% -c 7000.0,100% -p 1
après avoir recherché cette commande apparait sur le parent dont mon host hérite ...

j'ai modifié le parent pour lui mettre un template vide afin que mon check fonctionne mais cela ne change rien au probléme...

je viens de regardé mon fichier de conf et j'ai bien la commande correctement de paramétré
voici l'extrait du fichier concerné.

Code : Tout sélectionner

define service {
	host_name	mon_host_a_pinger
	service_description	check_ping
	max_check_attempts	4
	normal_check_interval	4
	active_checks_enabled	1
	passive_checks_enabled	1
	check_period	24x7
	parallelize_check	1
	obsess_over_service	0
	check_freshness	0
	freshness_threshold	0
	notification_interval	0
	notification_period	24x7
	notifications_enabled	1
	display_name	check_ping
	check_command	check_nrpe_ping!ipduhost
	notification_options	w,u,c,r,f,s
	stalking_options	o,w,u,c
}
j'ai même relancé nagios sans reboot du serveur mais cela ne change rien.

je n'y comprend plus rien...

Avatar du membre
Seb
Messages : 3556
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: check qui ne répond pas en mode web

Message par Seb » 08 juin 2017, 15:44

Hum ne mélangerais tu pas la notion de parent nagios et la notion d'héritage de template?
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

palouf34
Messages : 96
Enregistré le : 13 août 2015, 10:59
Localisation : saint-junien

Re: check qui ne répond pas en mode web

Message par palouf34 » 09 juin 2017, 08:48

non je ne pense pas confondre.

Pour être sur, j'ai créer un nouveaux host avec un nom différent, affecté un template vide et juste le service via nrpe et j’obtiens toujours le message

Code : Tout sélectionner

(return code of 127 is of bounds - plugins be missing)
alors que sur l'interface affiche bien la commande souhaité.

Avatar du membre
Seb
Messages : 3556
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: check qui ne répond pas en mode web

Message par Seb » 09 juin 2017, 09:33

pour reprendre tout ça dans l'ordre peux tu donner:

-La commande que tu as créé dans nagios command
-le template affecté a ton host
-la commande de host check mise en place (par dessus ton template j'imagine) et les arguments
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

palouf34
Messages : 96
Enregistré le : 13 août 2015, 10:59
Localisation : saint-junien

Re: check qui ne répond pas en mode web

Message par palouf34 » 09 juin 2017, 13:51

La comande nagios :

nom: check_ping_nrpe
command line : $user1$/check_nrpe -H ip du rebond -c check_ping -a $ARG1$
argument : ARG1=adresse ip distante

le template :
nom : TPL_VIde
héritage = vide
check: actif, 24*7
notification on : tout
stalking on : tout
service : aucun

Mon Host :
heritage: template ci dessus.
ip du host : x.x.x.x
service:
1 seul service:
nom: check_ping
héritage : generic_service
check: check_ping_nrpe

paramétre : $arg1$ = x.x.x.x (ip du ping)


voila comment est configurer mon host.


c'e petit état des lieux m'a permis de voir que le template _vide avait un service de pare-métré par défaut. j'en ai donc recréer un pour être sur qu'il n'y ais aucune commande d'affecté et que cela soit ma commande nrpe_check_ping qui soit pris dans le host.

Avatar du membre
Seb
Messages : 3556
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: check qui ne répond pas en mode web

Message par Seb » 09 juin 2017, 14:28

Ce que je ferais:

La commande nagios :

nom: check_ping_nrpe
command line : $USER1$/check_nrpe -H $ARG1$ -c check_ping -a $HOSTADDRESS$
argument : ARG1=adresse ip du rebond

le template :
nom : TPL_NRPE_PING_RBD1 (pour rebond1)
héritage = GENERIC-HOST
check: ecraser la commande check_host alive par la check_nrpe_ping
Mettre en check command parameter ARG1 ip du rebond.


Mon Host :
heritage: template ci dessus.
ip du host : x.x.x.x

Et hop!
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

palouf34
Messages : 96
Enregistré le : 13 août 2015, 10:59
Localisation : saint-junien

Re: check qui ne répond pas en mode web

Message par palouf34 » 13 juin 2017, 13:44

désolé mais cela ne fonctionne pas.... je tourne en bourrique ....
j'ai toujours le message

Code : Tout sélectionner

(return code of 127 is out of bounds - plugins may be missing)

Avatar du membre
Seb
Messages : 3556
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: check qui ne répond pas en mode web

Message par Seb » 13 juin 2017, 15:20

Et en page web du service concerné, quelle est la commande passée?
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Répondre