upgrade PHP 7

Laurentor999
Messages : 32
Inscription : 20 avril 2012, 07:45
Localisation : Nouméa

upgrade PHP 7

Message par Laurentor999 » 19 juin 2017, 07:47

Bonjour
Est-ce qu'il est possible d'upgrader le PHP 5.4.16 présent dans eon 5.1 en php 7 dernière version ?
En effet, nos auditeurs nous recommande de migrer en dernière version pour des raisons de sécurité.

Merci

Avatar de l’utilisateur
Seb
Messages : 3530
Inscription : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: upgrade PHP 7

Message par Seb » 19 juin 2017, 15:51

Vu l'impact je te déconseille de te lancer là dedans. Si c'est une contrainte de sécurité je te recommande FORTEMENT de te rapprocher d'Axians Cloud Builder pour envisager une prestation. Pourquoi pas avec un passage en 5.2 (prévue pour aout à priori) en plus?
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Laurentor999
Messages : 32
Inscription : 20 avril 2012, 07:45
Localisation : Nouméa

Re: upgrade PHP 7

Message par Laurentor999 » 21 juin 2017, 06:10

Oui j'ai abandonné l'idée d'un upgrade en php7 en revanche je viens de faire celui en php 5.6.30 via les repos webtatic.
Le seul truc que j'ai du modifier c'est le nom de la fonction ldap_escape() dans un des scripts d'eonweb, vu que c'est aussi le nom d'une fonction native de php 56 aussi !
Et ajout également du date.timezone dans le php.ini pour ne pas avoir d'erreur lors de l'export lilac.

après tout semble fonctionner correctement.

Merci

Yannick
Messages : 4
Inscription : 03 avril 2018, 11:15

Re: upgrade PHP 7

Message par Yannick » 10 septembre 2018, 11:35

Salut Laurentor999,

Peut-tu partager ta façon de procéder? Est-ce tout fonctionne encore après (glpi, nagios, ocs principalement)?

Est-ce que je peux utiliser ces lignes de commandes

rpm -Uvh https://mirror.webtatic.com/yum/el7/epel-release.rpm
rpm -Uvh https://mirror.webtatic.com/yum/el7/web ... elease.rpm
yum remove php-common (cette lignes pete tout, j'ai l'impression :oops: )
yum install -y php56w php56w-opcache php56w-xml php56w-mcrypt php56w-gd php56w-devel php56w-mysql php56w-intl php56w-mbstrin

Merci

Répondre