Création utilisateur LDAP

BaptisteM
Messages : 17
Enregistré le : 09 février 2017, 15:25

Création utilisateur LDAP

Message par BaptisteM » 15 mars 2017, 14:36

Bonjour,

je n'arrive pas à créer un utilisateur LDAP.
j'ai ce message qui s'affiche " EON - User / Group : User name can not be empty "


Mais comme vous pouvez le voir ci-dessous, si je coche utilisateur LDAP, le champ nom de l'utilisateur se grise. Je n'ai aucun autre emplacement ou je peux inscrire un UserName.

Image

J'ai trouvé un sujet un peu similaire sur le forum, mais la résolution se fait à l'aide du champ "login RDN", champ que je n'ai pas pour ma part...

Si vous avez une idée !

Merci

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Création utilisateur LDAP

Message par Seb » 16 mars 2017, 12:15

Il faut d'abord configurer administration / généralité / authentification pour ldap.....
Par ailleurs on ne créé pas DANS le ldap, on associe a un compte LDAP EXISTANT.
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

BaptisteM
Messages : 17
Enregistré le : 09 février 2017, 15:25

Re: Création utilisateur LDAP

Message par BaptisteM » 16 mars 2017, 12:29

Je comprends bien pour LDAP :geek:
C'est déjà le cas, vu que d'autres utilisateurs et moi même utilisons nos comptes AD pour nous connecter.

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Création utilisateur LDAP

Message par Seb » 16 mars 2017, 17:47

Et donc?
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Laurent Chevrier
Messages : 45
Enregistré le : 19 décembre 2016, 12:03

Re: Création utilisateur LDAP

Message par Laurent Chevrier » 29 mars 2017, 14:52

J'ai aussi le problème.

On dirait que l'interface n'enregistre pas les données saisies au niveau du formulaire dans la base.

Pour la config de l'authentification, j'ai été obligé d'aller écrire directement en base le filtre de recherche ou le user

BaptisteM
Messages : 17
Enregistré le : 09 février 2017, 15:25

Re: Création utilisateur LDAP

Message par BaptisteM » 20 juin 2017, 10:34

Seb a écrit :
16 mars 2017, 17:47
Et donc?
Et donc j'ai toujours pas de solution donc j'ai un peu abandonné, j'ai des comptes LDAP et des comptes MYSQL qui sont créés pour ceux qui ne fonctionnent pas en LDAP.

Image

Du moment ou je veux créer un compte en LDAP, j'ai le message ci-dessus qui me dit que le champ user ne peut être laissé vide. Mais vu qu'il est grisé, on ne peut rien mettre dans ce champ... Idem si on complète le champ Nom d'utilisateur et que l'on coche après Utilisateur LDAP.

Laurent Chevrier
Messages : 45
Enregistré le : 19 décembre 2016, 12:03

Re: Création utilisateur LDAP

Message par Laurent Chevrier » 20 juin 2017, 10:48

Vérifie que tu n'as pas le même problème que moi :
viewtopic.php?f=5&t=1882&p=12069#p12069

BaptisteM
Messages : 17
Enregistré le : 09 février 2017, 15:25

Re: Création utilisateur LDAP

Message par BaptisteM » 20 juin 2017, 15:19

Merci Laurent, j'ai lu le sujet mais je n'ai pas trouvé vraiment de relation et je n'ai pas tout compris il faut dire a votre finalité.
J'ai été parachuté sur un EON existant dont la VM a je pense été dupliqué d'une autre installée par APX. Et je nage un peu :)

Dans mon ldapggroups.sql j'ai cela :

Code : Tout sélectionner

ALTER TABLE auth_settings ADD COLUMN ldap_group_filter varchar(255);
ALTER TABLE auth_settings CHANGE ldap_filter ldap_user_filter varchar(255);
ALTER TABLE groups ADD COLUMN group_type tinyint(1);
ALTER TABLE groups ADD COLUMN group_dn varchar(255);
CREATE TABLE `ldap_groups_extended` (
  `dn` varchar(255) NOT NULL,
  `group_name` varchar(255) DEFAULT NULL,
  `checked` smallint(6) NOT NULL,
  PRIMARY KEY (`dn`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;
Mais je ne suis pas sur que le problème soit similaire.

Laurent Chevrier
Messages : 45
Enregistré le : 19 décembre 2016, 12:03

Re: Création utilisateur LDAP

Message par Laurent Chevrier » 20 juin 2017, 15:52

Est ce que vous avez renseigné les infos nécessaires à la connexion au serveur LDAP dans Administration -> Généralités -> authentification ?
Il faut mettre :
- la racine LDAP que vous souhaitez importer dans "Recherche DN', qqch du genre OU=mon_service,DC=mon_domaine,DC=fr
- (objectclass=user) et (objectclass=group) dans les filtres utilisateur et groupe
- samaccountname dans Login RDN
- et un utilisateur/mdp autorisé à lire la base LDAP


Si les infos sont correctes, çà devrait remplir les tables ldap_users_extended et ldap_groups_extended de la base eonweb avec les users et groups existants dans votre annuaire LDAP.

Si tout est correct dans cette 1ère étape, sur la page de création des comptes, il suffit de taper quelques lettres du nom d'une personne pour que cela vous le propose.

BaptisteM
Messages : 17
Enregistré le : 09 février 2017, 15:25

Re: Création utilisateur LDAP

Message par BaptisteM » 20 juin 2017, 16:05

Oui tout est renseigné, et cela fonctionne pour des utilisateurs.
Je vais vérifier ca et je reviens vous voir avec plus de détails.

Merci

Répondre