Impossible d'appliquer la configuration

namessi
Messages : 21
Enregistré le : 25 juin 2017, 01:15

Impossible d'appliquer la configuration

Message par namessi » 13 juillet 2017, 17:51

Bonjour chers tous,
J'ai un souci pour appliquer la configuration après un export de mes nouvelles machines.
Quand je fais l'export, le résultat est "Engine export process failed to complete successfully" et ça s'arrête après une seconde et voici les réponses qui s'affichent:
2017-07-13 15:27:26

ERROR

Engine export process failed to complete successfully.
2017-07-13 15:27:26

ERROR

Export failed.
2017-07-13 15:27:26

ERROR


2017-07-13 15:27:26

ERROR

'Whats New' section to find out what has changed.
2017-07-13 15:27:26

ERROR

the HTML documentation regarding the config files, as well as the
2017-07-13 15:27:26

ERROR

may have been removed or modified in this version. Make sure to read
2017-07-13 15:27:26

ERROR

version of Nagios, you should be aware that some variables/definitions
2017-07-13 15:27:26

ERROR

directives and data defintions. If you are upgrading from a previous
2017-07-13 15:27:26

ERROR

Check your configuration file(s) to ensure that they contain valid
2017-07-13 15:27:26

ERROR


2017-07-13 15:27:26

ERROR

***> One or more problems was encountered while running the pre-flight check...
2017-07-13 15:27:26

ERROR


2017-07-13 15:27:26

ERROR

Total Errors: 1
2017-07-13 15:27:26

ERROR

Total Warnings: 1
2017-07-13 15:27:26

ERROR


2017-07-13 15:27:26

ERROR

Checking misc settings...
2017-07-13 15:27:26

ERROR

Checking obsessive compulsive processor commands...
2017-07-13 15:27:26

ERROR

Checking global event handlers...
2017-07-13 15:27:26

ERROR

Checking for circular host and service dependencies...
2017-07-13 15:27:26

ERROR

Checking for circular paths between hosts...
J'ai déjà jeté un coup sur le forum mais la resolution de ces problèmes ne ressemblent pas au mien. comme celui ci:
viewtopic.php?f=15&t=1911


Je vous remercie pour toutes aides pouvant m'aider à avancer.......

namessi
Messages : 21
Enregistré le : 25 juin 2017, 01:15

Re: Impossible d'appliquer la configuration

Message par namessi » 14 juillet 2017, 17:29

Je viens de regarder dans le dossier /lilac-export-1 et je ne retrouve pas de de fichier nagios.cfg. Au fait le dossier est entièrement vide. Svp si vous avez des orientations à me donner je serais très heureuse

Avatar du membre
Akecc
Messages : 144
Enregistré le : 19 avril 2016, 16:24
Localisation : Saint-Brieuc

Re: Impossible d'appliquer la configuration

Message par Akecc » 18 juillet 2017, 11:30

Bonjour,

Pourrai tu lancer ton job ? Une fois que celui ci est fini, tu passe sur la deuxième page des résultats et tu reviens à la première, tu affiches les 50 premiers résultats puis tu les redonnes içi.
"C'est Darwin, tu t'adaptes ou tu dégages" :twisted:

namessi
Messages : 21
Enregistré le : 25 juin 2017, 01:15

Re: Impossible d'appliquer la configuration

Message par namessi » 24 juillet 2017, 12:01

Bonjour désolé pour mon retard.

2017-07-24 09:38:55
ERROR
Engine export process failed to complete successfully.
2017-07-24 09:38:55
ERROR
Export failed.
2017-07-24 09:38:55
ERROR

2017-07-24 09:38:55
ERROR
'Whats New' section to find out what has changed.
2017-07-24 09:38:55
ERROR
the HTML documentation regarding the config files, as well as the
2017-07-24 09:38:55
ERROR
may have been removed or modified in this version. Make sure to read
2017-07-24 09:38:55
ERROR
version of Nagios, you should be aware that some variables/definitions
2017-07-24 09:38:55
ERROR
directives and data defintions. If you are upgrading from a previous
2017-07-24 09:38:55
ERROR
Check your configuration file(s) to ensure that they contain valid
2017-07-24 09:38:55
ERROR

2017-07-24 09:38:55
ERROR
***> One or more problems was encountered while processing the config files...
2017-07-24 09:38:55
ERROR

2017-07-24 09:38:55
ERROR

2017-07-24 09:38:55
ERROR
Error processing object config files!
2017-07-24 09:38:55
ERROR
Error: Could not register host (config file '/tmp/lilac-export-1/objects/hosts.cfg', starting on line 31)
2017-07-24 09:38:55
ERROR
Error: Invalid max_check_attempts value for host 'Hansel.Loba'
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/escalations.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/dependencies.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/services.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/hosts.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/servicegroups.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/hostgroups.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/contactgroups.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/contacts.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/timeperiods.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config file '/tmp/lilac-export-1/objects/commands.cfg'...
2017-07-24 09:38:55
ERROR
Processing object config directory '/tmp/lilac-export-1/objects'...
2017-07-24 09:38:55
ERROR
Read main config file okay...
2017-07-24 09:38:55
ERROR
Reading configuration data...
2017-07-24 09:38:55
ERROR
Website: http://www.nagios.org
2017-07-24 09:38:55
ERROR

2017-07-24 09:38:55
ERROR
License: GPL
2017-07-24 09:38:55
ERROR
Last Modified: 08-30-2013
2017-07-24 09:38:55
ERROR
Copyright (c) 1999-2009 Ethan Galstad
2017-07-24 09:38:55
ERROR
Copyright (c) 2009-2011 Nagios Core Development Team and Community Contributors
2017-07-24 09:38:55
ERROR
Nagios Core 3.5.1
2017-07-24 09:38:55
ERROR

2017-07-24 09:38:55
ERROR
Nagios Sanity Check Failed. Did not write configuration files to production. Output is as follows:
2017-07-24 09:38:55
NOTICE
Finished exporting objects.
2017-07-24 09:38:55
NOTICE
NagiosEscalationExporter complete.
2017-07-24 09:38:55
NOTICE
Completed escalations export for host: Hansel.Loba
2017-07-24 09:38:55
NOTICE
Processing escalations for host: Hansel.Loba
2017-07-24 09:38:55
NOTICE
Completed escalations export for host: localhost
2017-07-24 09:38:55
NOTICE
Processing escalations for service: ssh on localhost
2017-07-24 09:38:55
NOTICE
Processing escalations for service: mysql on localhost
2017-07-24 09:38:55
NOTICE
Processing escalations for service: process_ged on localhost
2017-07-24 09:38:55
NOTICE
Processing escalations for service: interfaces on localhost
2017-07-24 09:38:55
NOTICE
Processing escalations for service: uptime on localhost
2017-07-24 09:38:55
NOTICE
Processing escalations for service: systime on localhost
2017-07-24 09:38:55
NOTICE
Processing escalations for service: partitions on localhost
2017-07-24 09:38:55
NOTICE
Processing escalations for service: memory on localhost
2017-07-24 09:38:55
NOTICE
Processing escalations for service: processor on localhost

Avatar du membre
Seb
Messages : 3410
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Impossible d'appliquer la configuration

Message par Seb » 25 juillet 2017, 14:23

Error: Could not register host (config file '/tmp/lilac-export-1/objects/hosts.cfg', starting on line 31)
2017-07-24 09:38:55
Edites ton fichier /tmp/systemd....httpd..../lilac-export-1/objects/hosts.cfg

Une fois dedans, fais un
:31

Qui va t'envoyer ligne 31. De là note le nom de l'host qui pose soucis et va régler ce pb dans l'interface nagios configuration, refais un export et hop....

Dans 90% des cas c'est quand on crée un hôte de 0, sans le faire hériter de "generic host" par exemple... et donc les valeurs chek-command, etc sont indéfinies.
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

namessi
Messages : 21
Enregistré le : 25 juin 2017, 01:15

Re: Impossible d'appliquer la configuration

Message par namessi » 27 juillet 2017, 19:08

Bonjour SEB, j'ai suivi tes instructions mais je ne retrouve pas le fichier " /tmp/systemd....httpd..../lilac-export-1/objects/hosts.cfg". je voulais vous presenter l'etat de mon répertoire tmp mais je n'arrive pas à exporter des images à partir du forum

namessi
Messages : 21
Enregistré le : 25 juin 2017, 01:15

Re: Impossible d'appliquer la configuration

Message par namessi » 27 juillet 2017, 19:25

Bonjour SEB, j'ai suivi tes instructions mais je ne retrouve pas le fichier " /tmp/systemd....httpd..../lilac-export-1/objects/hosts.cfg". Je vous montre l'etat de mon repertoire tmp:

https://drive.google.com/open?id=0B8_VL ... mFHaGI4UzA

Avatar du membre
Seb
Messages : 3410
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Impossible d'appliquer la configuration

Message par Seb » 28 juillet 2017, 15:14

Et donc???????

systemd-private-.....httpd.service... ça n'y ressemble pas fortement???? Peut être regarder ce qu'il y a dedans....
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

namessi
Messages : 21
Enregistré le : 25 juin 2017, 01:15

Re: Impossible d'appliquer la configuration

Message par namessi » 28 juillet 2017, 19:34

Bonsoir Seb, au fait je regarde l'interieur et je ne retrouve aucun fichier qui fait réference à lilac-export1. je vous montre une capture de l'etat de mon répertoire tmp.

https://drive.google.com/file/d/0B8_VLo ... sp=sharing

Avatar du membre
Seb
Messages : 3410
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Impossible d'appliquer la configuration

Message par Seb » 28 juillet 2017, 21:10

regarde les dates du systemd....httpd.service....
choisis le plus récent. dedans créé un lilac-export-1 et met les droits 777 sur ce répertoire. Refait ton job pour voir. A l'issue retourne voir si il y a des fichiers cfg dedans.
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité