ndoutils-async

Répondre
SNMP4u
Messages : 32
Enregistré le : 05 mars 2013, 20:55

ndoutils-async

Message par SNMP4u » 12 avril 2013, 10:52

Bonjour,

J'ai un petit problème dans mes logs "Messages" je reçois plusieurs fois le message: "ndo2db-3x: Error: queue send error."

J'ai vu qu'il existait un patch pour résoudre ce problème mais je ne sais pas comment l'appliquer dans NDOutils.

Patch: ndoutils-async-v1.1.patch
http://exchange.nagios.org/directory/Pa ... nc/details

Merci d'avance.

Avatar du membre
Guiona
Messages : 762
Enregistré le : 18 janvier 2012, 16:36
Localisation : Toulouse
Contact :

Re: ndoutils-async

Message par Guiona » 12 avril 2013, 11:56

Pour appliquer un patch de ce type il faut le faire dans le code source http://www.cyberciti.biz/faq/appy-patch ... h-command/
La connaissance appartient à ceux qui la partagent.

SNMP4u
Messages : 32
Enregistré le : 05 mars 2013, 20:55

Re: ndoutils-async

Message par SNMP4u » 12 avril 2013, 14:43

Ok j'aurais appris une commande aujourd'hui.

Par contre, le patch je dois l'appliquer à un binaire donc j'ai voulu appliquer le patch à ndo2db-3x se trouvant dans /srv/eyesofnetwork/nagios/bin/ndo2db-3x mais il n'arrive pas à s'appliquer et il me retourne 6 out of 6 hunks FAILED.

Pour le moment j'ai modifié mes paramètres de messages dans sysctl.conf mais le problème reviendra plus tard.

Personne ne rencontre le problème de "ndo2db-3x: Error: queue send error." ?

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: ndoutils-async

Message par Seb » 12 avril 2013, 18:03

En même temps plus grand monde utilise ndo2db....et lui préfère livestatus.
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

SNMP4u
Messages : 32
Enregistré le : 05 mars 2013, 20:55

Re: ndoutils-async

Message par SNMP4u » 15 avril 2013, 10:20

Ok mais en relisant la doc de EON sur la modification du backend Livestatus, j'ai bien mes fichiers de configurés mais à présent dans nagvis mes équipements affichent "does not exist (hostState)" et dans /log/rw/live j'ai permission denied même en mettant les droits 755. Quelles sont les fichiers à configurer mise à part le /etc/xinet.d/central et nagvis.ini.php?

Merci d'avance.

EDIT:

je viens de remarquer que lorsque je restart nagios j'ai encore ndomod qui se lance et livestatus ne créer pas de socket:

Code : Tout sélectionner

Apr 15 10:35:36 EON nagios: livestatus: Socket thread has terminated
Apr 15 10:35:36 EON nagios: Event broker module '/srv/eyesofnetwork/mk-livestatus/lib/livestatus.o' deinitialized successfully.
Apr 15 10:35:36 EON nagios: Nagios 3.4.1 starting... (PID=32103)
Apr 15 10:35:36 EON nagios: Local time is Mon Apr 15 10:35:36 CEST 2013
Apr 15 10:35:36 EON nagios: LOG VERSION: 2.0
Apr 15 10:35:36 EON nagios: ndomod: NDOMOD 1.5 (02-03-2012) Copyright (c) 2009 Nagios Core Development Team and Community Contributors
Apr 15 10:35:36 EON nagios: ndomod: Successfully connected to data sink.  0 queued items to flush.
Apr 15 10:35:36 EON nagios: Event broker module '/srv/eyesofnetwork/nagios/bin/ndomod-3x.o' initialized successfully.
Apr 15 10:35:36 EON nagios: livestatus: Livestatus 1.2.0p1 by Mathias Kettner. Socket: '/srv/eyesofnetwork/nagios/var/log/rw/live'
Apr 15 10:35:36 EON nagios: livestatus: Please visit us at http://mathias-kettner.de/
Apr 15 10:35:36 EON nagios: livestatus: Hint: please try out OMD - the Open Monitoring Distribution
Apr 15 10:35:36 EON nagios: livestatus: Please visit OMD at http://omdistro.org
Apr 15 10:35:36 EON nagios: livestatus: Finished initialization. Further log messages go to /srv/eyesofnetwork/nagios/var/log/livestatus.log
Apr 15 10:35:36 EON nagios: Event broker module '/srv/eyesofnetwork/mk-livestatus/lib/livestatus.o' initialized successfully.
Apr 15 10:35:36 EON nagios: Finished daemonizing... (New PID=32108)
Apr 15 10:35:36 EON nagios: TIMEPERIOD TRANSITION: 24x7;-1;1
Apr 15 10:35:36 EON nagios: TIMEPERIOD TRANSITION: workhours;-1;1
Et dans les logs de livestatus j'ai le message suivant : Warning: StatsGroupBy is deprecated. Please use Columns instead.

Je vais essayer de résoudre ce problème.

Re-EDIT: Je viens de résoudre mon problème dans nagvis en supprimant mes objets et en les recréant par contre j'ai toujours le warning dans livestatus.log.

Répondre