Nagiosbp configuration

Ricky
Messages : 21
Enregistré le : 14 mars 2014, 17:00

Re: Nagiosbp configuration

Message par Ricky » 03 juin 2014, 07:29

Bein, il se trouve que mon processeur n'est pas compatible à la version 4.x.Cette version requiert un processeur qui peut supporter à la fois le x86 et le x64!!!De plus je n'ai plus le temps car mon stage prend fin cette semaine!!vraiment désolé!!!Est-il possible de chercher d'autres solutions pour remedier à mon probléme!!?

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Nagiosbp configuration

Message par Seb » 03 juin 2014, 17:45

De mémoire tu peux l'éditer par le portail administration, un menu de gauche doit s'appeler applications métier ou processus...qui va t'editer le fichier de conf nagiosbp un peu comme pour snmp...tu dois vérifier dans ce fichier de configuration que le service métier Eyesofnetwork est bien la somme (ET logique) des services mysql, etc...de localhost...
En lisant correctement le fichier de conf et en comparant avec le portail "nagios configuration" tu dois voir les mêmes noms d'host et services!

Au pire copy ici le contenu du fichier de configuration nagiosbp qui gère le processus "eyesofnetwork".
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Ricky
Messages : 21
Enregistré le : 14 mars 2014, 17:00

Re: Nagiosbp configuration

Message par Ricky » 04 juin 2014, 06:58

Bonjour,
je peux pas installer la version 4.x à cause de mon processeur 32 bits!!!! j'espére qu'il y a d'autres solutions!!!

Ricky
Messages : 21
Enregistré le : 14 mars 2014, 17:00

Re: Nagiosbp configuration

Message par Ricky » 11 juin 2014, 09:47

Bonjour,
je crois que j'ai trouvé la solution Seb. En fait, par défaut le nom du serveur est localhost, alors il se trouve que j'ai modifié le nom de mon serveur, ce qui a entraîné l'état des applications vides dans mon nagiosbp. Il suffit juste alors que je remplace le "localhost" avec le nom de mon serveur et toute est redevenu normal!!!!!Merçi qu'on même pour la suggestion!!

Tazmani014
Messages : 30
Enregistré le : 22 février 2016, 14:03

Re: Nagiosbp configuration

Message par Tazmani014 » 12 avril 2016, 14:02

Bonjour,

Je voudrais m'attaquer à la supervision des applications métiers de l'entreprise où je travaille, il s'agit d'un hôpital et il dispose de pas mal de processus métiers (messagerie, interface web, système d'information hospitalier, et plein d'autres applications).
En lisant sur les forums, j'ai trouvé que NagiosBP répond à ce besoin.
Cependant, je ne sais comment procéder à la configuration du fichier /srv/eyesofnetwork/nagiosbp/etc/nagios-bp.conf.
Existerait-il un tutoriel que je pourrais suivre?

Merci pour votre aide.

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Nagiosbp configuration

Message par Seb » 12 avril 2016, 21:38

Bonjour!
Passez plutot par l'interface web, section administration, applications métiers :)
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Tazmani014
Messages : 30
Enregistré le : 22 février 2016, 14:03

Re: Nagiosbp configuration

Message par Tazmani014 » 14 avril 2016, 16:29

Merci beaucoup Seb, je ne sais pas ce que j'aurais fait dans mon projet sans votre aide.

J'ai fait ce que vous m'avez recommandé et ca marche très bien. J'ai un seul soucis par contre, dans le champ commande, je sais pas quoi saisir ni sa relation avec le processus. Je voudrais bien plus d'éclaircissement par rapport à ce point. (Je sais pourtant que le résultat de la commande est affiché dans le champ Informations sur le statut)

Un autre aspect des NagiosBP est la vue des impacts, je me demandais quel était son intérêt et comment elle marche.

Je vous remercie encore une fois.

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Nagiosbp configuration

Message par Seb » 14 avril 2016, 22:14

Pour le champ commande, laissez vierge mettez juste un nom pour ce processus, choisissez si il fera des ET ou des OU, etc... et faites add.
Vous arrivez ensuite dans l'ajout des services qui vont servir a donner l'état du process... cochez à droite "use a list", choisissez host, service, le process dont il fait partie... puis add, passez au service suivant qui compose le processus....

Sur ces services sera fait un ET ou un OU suivant le choix du départ.... A noter qu'ensuite il est possible de faire des ET, OU,.. entre des process :)

Enfin, la vue impact vous permet de voir l’état de vos process si vous changez a la main l'état d'un service... pour prévoir par exemple l'impact du maintenance d'un serveur sur vos service intranet...
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Tazmani014
Messages : 30
Enregistré le : 22 février 2016, 14:03

Re: Nagiosbp configuration

Message par Tazmani014 » 15 avril 2016, 02:51

Bien entendu Seb. Je laisse le champ Command vide et il n'y aura pas d'informations sur le statut du process.
Pour le reste, vous répondez à toutes mes questions et c'est très clair.

Merci infiniment et bonne fin soirée :P

Tazmani014
Messages : 30
Enregistré le : 22 février 2016, 14:03

Re: Nagiosbp configuration

Message par Tazmani014 » 22 avril 2016, 14:53

Rebonjour les amis,

En configurant les processus métiers, j'ai rencontré un problème au niveau de l'ajout des services d'un host particulier.
Au fait, au niveau d'un équipement, j'ai ajouté une dizaine de services. Mais sur la liste déroulante du champ service dans CONFIGURATION PROCESSUS MÉTIER, seul 2 ou 3 apparaissent, je n'arrive pas à comprendre pourquoi!

Merci de m'éclairer sur ce point.

Répondre