[RESOLU] CACTI acces denied

Répondre
tony07
Messages : 85
Enregistré le : 14 décembre 2010, 10:33

[RESOLU] CACTI acces denied

Message par tony07 » 12 mars 2012, 18:27

Bonsoir,
depuis que j'ai passé mon cacti en Web Basic Authentication j'ai cette erreur suivante lorsque j'essaye d'aller sur Cacti :
Error: Access Denied, please contact you Cacti Administrator.

comment reprendre la main sur cacti ?

Merci
Modifié en dernier par tony07 le 20 mars 2012, 19:57, modifié 1 fois.

tony07
Messages : 85
Enregistré le : 14 décembre 2010, 10:33

Re: (CACTI) acces denied

Message par tony07 » 12 mars 2012, 19:30

c'est bon j'ai trouvé une commande pour résoudre mon problème.

mysql cacti
update settings set value=1 where name='auth_method';

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: (CACTI) acces denied

Message par Seb » 12 mars 2012, 20:10

Pensez a d'abord creer un user avant de changer la methode d'authentif!
Sinon regardez la doc de la v2.2 "configuration" pour avoir quelques infos de plus sur les "autres" methodes d'authentif!
+++
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

tony07
Messages : 85
Enregistré le : 14 décembre 2010, 10:33

Re: (CACTI) acces denied

Message par tony07 » 14 mars 2012, 22:22

javais pourtant créer un user, c'est pour ça que je comprenais pas.

Guizber
Messages : 28
Enregistré le : 01 février 2013, 11:46

Re: [RESOLU] CACTI acces denied

Message par Guizber » 15 février 2013, 08:53

Même erreur après avoir passé mon cacti en Web Basic Authentication.
J'ai essayé la commande de tony07 mais après avoir tappé "mysql cacti" j'ai le message d'erreur suivant:

"ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)"

En me connectant en root ou en utilisateur normal, pas de changement.

Vais-je un jour pouvoir retourner sur mon petit cacti? :(

Avatar du membre
Guiona
Messages : 762
Enregistré le : 18 janvier 2012, 16:36
Localisation : Toulouse
Contact :

Re: [RESOLU] CACTI acces denied

Message par Guiona » 15 février 2013, 10:00

1 - se connecter à la base de données --> mysql -u root -p
2 - mdp --> root66
3 - use cacti;
4 - update settings set value = 1 where name = "auth_method";
5 - quit
La connaissance appartient à ceux qui la partagent.

Guizber
Messages : 28
Enregistré le : 01 février 2013, 11:46

Re: [RESOLU] CACTI acces denied

Message par Guizber » 15 février 2013, 10:22

Super, voilà une partie du problème de réglée!

Maintenant j'accède à cette page :

Image

Mais il m'est impossible de trouver quel login/mdp mettre!
Il ne me semble pas en avoir spécifié un de particulier pour Cacti, et les logs administrateur de mon serveur, de mon interface EonWeb ou même de mon propre poste (c'est dire que j'ai essayé tout et n'importe quoi) ne marchent pas.

J'ai pourtant essayé de reset le mdp, j'ai redemarré les services après (http, nagios, snmp... plus on en fait plus on est sur hein), mais ne peux quand même pas m'y connecter.

Je n'avais jusque là pas eu besoin de m'identifier sur cacti, comment se fait-ce?

Avatar du membre
Guiona
Messages : 762
Enregistré le : 18 janvier 2012, 16:36
Localisation : Toulouse
Contact :

Re: [RESOLU] CACTI acces denied

Message par Guiona » 15 février 2013, 13:35

C'est à toi de nous dire ce que tu as fait afin que l'on comprenne ce qui se passe mais à première vue tu as changer le système d'authentification au niveau de cacti... Par contre au niveau d'Apache tu as fait quoi?
La connaissance appartient à ceux qui la partagent.

Guizber
Messages : 28
Enregistré le : 01 février 2013, 11:46

Re: [RESOLU] CACTI acces denied

Message par Guizber » 18 février 2013, 07:42

Et bien je n'ai rien fais de plus que passer Cacti en Web Basic Authentication, et ai autorisé les utilisateurs "guest" à consulter cacti (en donnant seulement la permission de voir les remontées de performances). Ensuite j'ai eu le message d'erreur dont j'ai parlé un peu plus haut, que j'ai résolu grâce à ta méthode Guiona. Rien de plus au niveau de apache2, si ce n'est redémarrer mon service http... Y a-t-il un fichier ou je pourrais vérifier si les informations sont pertinentes? Mon nagios.cfg se porte bien apparemment.

Par contre j'ai fais un "yum update", je me demande si apache ne s'est pas mis à jour au passage


EDIT: Après un nombre incalculable de tentatives pour réinitialiser le mot de passe, le changer, ou le supprimer, j'ai fini par tout réinstaller. Tout remarche donc comme avant

Répondre