Probleme de dependance pour gammu.

EyesOfNetwork English Forum
Répondre
anicet
Messages : 17
Enregistré le : 01 septembre 2015, 13:24

Probleme de dependance pour gammu.

Message par anicet » 27 novembre 2016, 14:29

Bonjour a tous .je tient avant tous a vous demander votre clemance... (parce que j'imagine que je doit deja vous embeter avec mon probleme de gammu ci :D ).
Bon voila, j'ai deux serveurs (un pour la supervision: EON 5 ; et un autre qui me sert de passerel sms)
Bref j'ai envi de reunir les deux sur une meme machine. j(ai donc desider d'ajouter mon module sms directement a EON)
mon petit programme sms fonctionne avec gammu.
le probleme est que quant je veut installer gammu ca me met une erreur.

Code : Tout sélectionner

 [root@localhost]# yum install gammu-1.37.91-1.1.x86_64.rpm
Modules complémentaires chargés : fastestmirror
Examen de gammu-1.37.91-1.1.x86_64.rpm : gammu-1.37.91-1.1.x86_64
Sélection de gammu-1.37.91-1.1.x86_64.rpm pour installation
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet gammu.x86_64 0:1.37.91-1.1 sera installé
--> Traitement de la dépendance : libGammu.so.8()(64bit) pour le paquet : gammu-  1.37.91-1.1.x86_64
base                                                     | 3.6 kB     00:00
extras                                                   | 3.4 kB     00:00
updates                                                  | 3.4 kB     00:00
Loading mirror speeds from cached hostfile
 * base: mirror.steadfast.net
 * epel: mirror.bytemark.co.uk
 * extras: mirror.steadfast.net
 * updates: mirror.steadfast.net
--> Résolution des dépendances terminée
[b]Erreur[/b] : Paquet : gammu-1.37.91-1.1.x86_64 (/gammu-1.37.91-1.1.x86_64)
             Requiert : libGammu.so.8()(64bit)
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest
j'ai meme essayer d'installer la librerie suitvante. mais nouvelle erreur:

Code : Tout sélectionner

[root@localhost]# yum install libgsmsd7-1.34.0-13.1.x86_64.rpm
Modules complémentaires chargés : fastestmirror
Examen de libgsmsd7-1.34.0-13.1.x86_64.rpm : libgsmsd7-1.34.0-13.1.x86_64
Sélection de libgsmsd7-1.34.0-13.1.x86_64.rpm pour installation
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet libgsmsd7.x86_64 0:1.34.0-13.1 sera installé
--> Traitement de la dépendance : libGammu.so.7()(64bit) pour le paquet : libgsmsd7-1.34.0-13.1.x86_64
Loading mirror speeds from cached hostfile
 * base: mirror.steadfast.net
 * epel: mirror.bytemark.co.uk
 * extras: mirror.steadfast.net
 * updates: mirror.steadfast.net
--> Traitement de la dépendance : libdbi.so.0()(64bit) pour le paquet : libgsmsd7-1.34.0-13.1.x86_64
--> Lancement de la transaction de test
---> Le paquet libdbi.x86_64 0:0.8.4-6.el7 sera installé
---> Le paquet libgsmsd7.x86_64 0:1.34.0-13.1 sera installé
--> Traitement de la dépendance : libGammu.so.7()(64bit) pour le paquet : libgsmsd7-1.34.0-13.1.x86_64
--> Résolution des dépendances terminée
Erreur : Paquet : libgsmsd7-1.34.0-13.1.x86_64 (/libgsmsd7-1.34.0-13.1.x86_64)
             [b][u]Requiert : libGammu.so.7()(64bit)[/u][/b]
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest
svp qu'elle qu'un pour m'aider a resoudre ce probleme.

Certain me diront d'utiliser gnokii qui est deja present sur la version EON 5 !!!! :geek:
le probleme est que j'ai ecri un petit script php qui fonctionne avec gammu. et de plus gammu a l'option "RunOnReceive" qui permet de lancer un script a la reception d'un sms. j'ai pas vu un truc semblable dans le fichier de configuration de gnokii.
Donc :roll:

niccin
Messages : 1
Enregistré le : 06 décembre 2016, 09:46

Re: Probleme de dependance pour gammu.

Message par niccin » 06 décembre 2016, 16:56

Salut,
Je te conseille d'aller jeter un coup d'oeil sur ce site, qui explique assez bien, avec les liens pour récupérer les paquets, comment installer GAMMU sur CentOS7 : http://www.samgalope.com/2016/09/03/bui ... way-gammu/

Avatar du membre
Seb
Messages : 3556
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Probleme de dependance pour gammu.

Message par Seb » 08 décembre 2016, 12:59

Merci du retour ;)
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Répondre