Configuration EON et GLPI

Bedoui
Messages : 25
Enregistré le : 04 août 2017, 13:19

Configuration EON et GLPI

Message par Bedoui » 05 août 2017, 12:16

Bonjour eyesOfNetwork community,

Pour le besoin de notre groupe et pour la supervision et la bonne gestion de notre parc informatique nous avons opté pour EON comme solution.

Pour le moment l'installation du serveur 5.0 est bien faite sur une machine dédié.
Concernant la détection des machines ,j'ai suivi la documentation en activant le service SNMP sur une machine et en acceptant les requêtes venant du serveur mais sans résultats :?
Autre question est ce que je devrais faire ceci pour toutes les machines (plus que 500 machines).
Finalement concernant l'intégration avec OCS et glpi et AD la version 5.0 est elle stable .
Merci infiniment et bon weekend .

Avatar du membre
Seb
Messages : 3430
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Configuration EON et GLPI

Message par Seb » 06 août 2017, 18:36

Concernant la détection des machines ,j'ai suivi la documentation en activant le service SNMP sur une machine et en acceptant les requêtes venant du serveur mais sans résultats
Et donc? tu as créé un job autodiscover????
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Bedoui
Messages : 25
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 07 août 2017, 10:28

Bonjour

j'ai lancé une découverte via Outils/Découverte ensuite j'ai crée un job autodiscovery en mentionnant l@Ip de la machine que je vais supervisé .
le service snmp de cette machine accepte les paquets snmp provenant de la hôte de serveur ainsi que, à titre d'info, j'ai gardé le nom de la communauté par défaut "EyesOfNetwork".

J'estime que je suis sur la bonne voix .

Bedoui
Messages : 25
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 07 août 2017, 12:25

ReBonjour,
j'ai lancé cette commande via l'interface de configuration
Commande exécutée : snmpwalk -c EyesOfNetwork -v 2c @Ip
avec @Ip est la machine dont le snmp est activé et il accepte les requêtes provenant des hotes du serveur ainisi que lorsque je lance une traceroute @ip pas de passage vers le firewall .

Avatar du membre
Akecc
Messages : 146
Enregistré le : 19 avril 2016, 16:24
Localisation : Saint-Brieuc

Re: Configuration EON et GLPI

Message par Akecc » 07 août 2017, 12:26

Arrive tu as requêter la machine que tu veuille superviser ? lance un ping vers ta machine depuis ton serveur de supervision.
Si tu as autant de machines déployées, tu dois avoir ton serveur de placé dans la DMZ ? As-tu les autorisations pour sortir de la dmz vers ton réseau interne ?
"C'est Darwin, tu t'adaptes ou tu dégages" :twisted:

Bedoui
Messages : 25
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 07 août 2017, 12:34

Bon comme j'ai mentionné depuis mon serveur:
le ping de la machine à superviser OK
traceroute pas de passage vers le firewall OK
via l'onglet outils et production (mime sur le console bien sure ):Commande exécutée : snmpwalk -c EyesOfNetwork -v 2c 192.168.42.224 OK
Donc il est prévu que la machine soit détectée(2quipements nagios) sauf si j'ai oublié une configuration .

Merci

Avatar du membre
Akecc
Messages : 146
Enregistré le : 19 avril 2016, 16:24
Localisation : Saint-Brieuc

Re: Configuration EON et GLPI

Message par Akecc » 07 août 2017, 12:39

As tu le pare-feu d'activé sur ta station ? Si oui, désactive le et refais un test.

As-tu un bon filtre pour ton job ? https://nmap.org/book/man-target-specification.html
"C'est Darwin, tu t'adaptes ou tu dégages" :twisted:

Bedoui
Messages : 25
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 07 août 2017, 12:47

les pare-feu sur la station de test sont désactivés .
Concernant les filtres j'ai pas compliqué les choses, dans le job j'ai mentionné que l'@ip de la station à tester

Bedoui
Messages : 25
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 07 août 2017, 13:17

voilà plus de détails si je lance un job, rien à signaler, il a détecté le nom du hôte ainsi que plus de détails mais lors de retour "Reviewing found devices" No Devices Available For Import est affiché

2017-08-04 09:15:30
NOTICE
Completed Auto Discovery.
2017-08-04 09:15:30
NOTICE
Tracerouting skipped. Hosts will be set as top-level.
2017-08-04 09:15:30
NOTICE
Engine completed discovering devices
2017-08-04 09:15:30
NOTICE
Added devices and services.
2017-08-04 09:15:30
NOTICE
Device appears to already be in configuration under hostname: host. Skipping.
2017-08-04 09:15:30
NOTICE
Found xx.xx.xx.xx:yyyy.
2017-08-04 09:15:30
NOTICE
Number of hosts: 1
2017-08-04 09:15:30
NOTICE
Nmap finished discovery. Now reading in result XML.
2017-08-04 09:15:30
NOTICE
NMAP: Raw packets sent: 1453 (64.630KB) | Rcvd: 677 (27.786KB)
2017-08-04 09:15:30
NOTICE
NMAP: Nmap done: 1 IP address (1 host up) scanned in 76.31 seconds
2017-08-04 09:15:30
NOTICE
NMAP: OS and Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
2017-08-04 09:15:30
NOTICE
NMAP: Read data files from: /usr/bin/../share/nmap
2017-08-04 09:15:30
NOTICE
NMAP: NSE: Script Post-scanning.
2017-08-04 09:15:30
NOTICE
NMAP: 1 0.56 ms yyyy (xx.xx.xx.xx)
2017-08-04 09:15:30
NOTICE
NMAP: HOP RTT ADDRESS
2017-08-04 09:15:30
NOTICE
NMAP: TRACEROUTE
2017-08-04 09:15:30
NOTICE
NMAP: |_smbv2-enabled: Server supports SMBv2 protocol
2017-08-04 09:15:30
NOTICE
NMAP: |_ Message signing disabled (dangerous, but default)
2017-08-04 09:15:30
NOTICE
NMAP: | SMB Security: Challenge/response passwords supported
2017-08-04 09:15:30
NOTICE
NMAP: | User-level authentication

Avatar du membre
Akecc
Messages : 146
Enregistré le : 19 avril 2016, 16:24
Localisation : Saint-Brieuc

Re: Configuration EON et GLPI

Message par Akecc » 07 août 2017, 13:32

Vu ton problème je continue a penser qu'il s'agit d'un problème réseau, as-tu une passerelle vers le réseau ou est situé ton pc test ?
"C'est Darwin, tu t'adaptes ou tu dégages" :twisted:

Répondre