Configuration EON et GLPI

Bedoui
Messages : 35
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 07 août 2017, 14:09

les deux machines (serveur et test) se situent dans le même réseau et ont la même passerelle par défault

Avatar du membre
Seb
Messages : 3558
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Configuration EON et GLPI

Message par Seb » 08 août 2017, 07:51

Merci de poster ce que tu as rempli lors de la création de ton job autodiscover ;)
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Bedoui
Messages : 35
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 08 août 2017, 08:51

Bonjour ,
j'ai crée le job en mentionnant que l'adresse IP de la machine de test (qui accepte déjà les requêtes snmp provenant de la hote serveur) qui se trouve sous le meme réseau du serveur
Elapsed Time: 0 Hours 1 Minutes 16 Seconds
Current Status: Finished.

Auto-Discovery Complete. Click to Continue To Reviewing Found Devices

No Devices Available For Import

puis si j'essaye d'appliquer la configuration sur le job nagios j'aurais Engine export process failed to complete successfully.
Image

Job Supplemental:
Performing Preflight Check With Command: /srv/eyesofnetwork/nagios/bin/nagios -v /tmp/lilac-export-1/nagios.cfg
Performing Nagios Restart With Command: /usr/bin/sudo /bin/systemctl restart nagios

2017-08-08 08:37:03
ERROR
Engine export process failed to complete successfully.
2017-08-08 08:37:03
ERROR
Export failed.
2017-08-08 08:37:03
ERROR

2017-08-08 08:37:03
ERROR
'Whats New' section to find out what has changed.
2017-08-08 08:37:03
ERROR
the HTML documentation regarding the config files, as well as the
2017-08-08 08:37:03
ERROR
may have been removed or modified in this version. Make sure to read
2017-08-08 08:37:03
ERROR
version of Nagios, you should be aware that some variables/definitions
2017-08-08 08:37:03
ERROR
directives and data defintions. If you are upgrading from a previous
2017-08-08 08:37:03
ERROR
Check your configuration file(s) to ensure that they contain valid
2017-08-08 08:37:03
ERROR

2017-08-08 08:37:03
ERROR
***> One or more problems was encountered while processing the config files...
2017-08-08 08:37:03
ERROR

2017-08-08 08:37:03
ERROR

2017-08-08 08:37:03
ERROR
Error processing object config files!
2017-08-08 08:37:03
ERROR
Error: Could not register host (config file '/tmp/lilac-export-1/objects/hosts.cfg', starting on line 58)
2017-08-08 08:37:03
ERROR
Error: Invalid max_check_attempts value for host 'xxxxx'
2017-08-08 08:37:03
ERROR
Processing object config file '/tmp/lilac-export-1/objects/escalations.cfg'...
2017-08-08 08:37:03
ERROR
Processing object config file '/tmp/lilac-export-1/objects/dependencies.cfg'...
2017-08-08 08:37:03
ERROR
Processing object config file '/tmp/lilac-export-1/objects/services.cfg'...
2017-08-08 08:37:03
ERROR
Processing object config file '/tmp/lilac-export-1/objects/hosts.cfg'...

Bedoui
Messages : 35
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 08 août 2017, 09:48

j'ai re-installé EON 5.0 vu que j'en doute des erreurs dans la manipulation des fichiers de config

j'ai utilisé la configuration par défault.

j'ai eu le meme constat

Image

puis

Image

ainsi que bien sure aucun équipement nagios sauf 'localhost' est ajouté .

Avatar du membre
Akecc
Messages : 171
Enregistré le : 19 avril 2016, 16:24
Localisation : Saint-Brieuc

Re: Configuration EON et GLPI

Message par Akecc » 08 août 2017, 10:25

Peux tu ajouter les images d'une autre manière ?
"C'est Darwin, tu t'adaptes ou tu dégages" :twisted:

Bedoui
Messages : 35
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 08 août 2017, 10:50

voilà
Image

et l’échec d'application de configuration

Image

Avatar du membre
Akecc
Messages : 171
Enregistré le : 19 avril 2016, 16:24
Localisation : Saint-Brieuc

Re: Configuration EON et GLPI

Message par Akecc » 08 août 2017, 11:44

Personnellement je n'y ai toujours pas accès ?
Peux-tu les déposer avec un hebergeur d'image ?
"C'est Darwin, tu t'adaptes ou tu dégages" :twisted:

Bedoui
Messages : 35
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 08 août 2017, 11:50

par un clic droit sur l'image: ouvrir l'image dans une nouvelle onglet ou la copie des url
bref voilà les url

http://ibb.co/gAG7Ba

http://ibb.co/cOitjv

Bedoui
Messages : 35
Enregistré le : 04 août 2017, 13:19

Re: Configuration EON et GLPI

Message par Bedoui » 08 août 2017, 12:55

voilà mon souci je voulais que via "Equipements Nagios" je pourrais superviser les machines importés
actuellement on est là

https://ibb.co/bJbz7F

Image

https://ibb.co/fjrz7F

Image

Avatar du membre
Akecc
Messages : 171
Enregistré le : 19 avril 2016, 16:24
Localisation : Saint-Brieuc

Re: Configuration EON et GLPI

Message par Akecc » 08 août 2017, 13:23

Image

Je sais pas comment tu importe tes images .... ?

Ton problème n'est pas avec le job d'auto discovery mais un job de restart nagios ! As-tu appliqué un template aux équipements importés ?
"C'est Darwin, tu t'adaptes ou tu dégages" :twisted:

Répondre