Images Utilisateurs - DashBoard Thruk

Répondre
FranckB
Messages : 25
Enregistré le : 06 février 2018, 15:30

Images Utilisateurs - DashBoard Thruk

Message par FranckB » 27 février 2018, 10:22

Bonjour à tous,

J'essaie depuis environ 2h d'afficher une image de fond et des images statiques dans un tableau de bord Thruk.

J'ai déjà été obligé de créer moi-même les répertoires, puisque "/srv/eyesofnetwork/thruk/usercontent" n'existait pas dans l'arborescence créée lors de l'installation EON.

Donc maintenant j'arrive bien à "uploader" les images depuis Thruk, elles apparaissent dans les listes déroulantes et on peut les sélectionner, sauf qu'elles ne s'affichent pas. Pour l'image de fond par exemple, on voit juste le cadre vide de l'image...

Merci pour votre aide.

Avatar du membre
Seb
Messages : 3543
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Images Utilisateurs - DashBoard Thruk

Message par Seb » 27 février 2018, 11:23

Je pencherais pour un pb de droits sur le rep, pas d'erreurs dans les logs apache?
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

FranckB
Messages : 25
Enregistré le : 06 février 2018, 15:30

Re: Images Utilisateurs - DashBoard Thruk

Message par FranckB » 27 février 2018, 13:25

J'ai tout mis en 777 pour les droits.

Je connais pas Apache, je vais aller fouiner de ce côté...

FranckB
Messages : 25
Enregistré le : 06 février 2018, 15:30

Re: Images Utilisateurs - DashBoard Thruk

Message par FranckB » 27 février 2018, 16:03

Il y a bien une erreur dans le /var/log/httpd/error_log, il ne trouve pas le répertoire user_content/images,
mais pas d'erreur concernant le répertoire user_content/backgrounds, et pourtant ça bug dans les deux cas.

En plus le log ne s'est pas mis à jour depuis ce matin 11h, donc je n'ai peut-être pas les derniers bon messages d'erreur. Est-ce qu'il y a un moyen de déclencher la mise à jour des log (si tant est que la question ait un sens) ?

Avatar du membre
Seb
Messages : 3543
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Images Utilisateurs - DashBoard Thruk

Message par Seb » 28 février 2018, 09:32

Je vous invite donc à créer le répertoire images avec les bons droits puis de relancer apache via un systemctl restart httpd
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

FranckB
Messages : 25
Enregistré le : 06 février 2018, 15:30

Re: Images Utilisateurs - DashBoard Thruk

Message par FranckB » 06 mars 2018, 11:44

Alors, pour l'image en background, l'upload depuis l'interface Thruk charge les fichiers dans le répertoire /srv/eyesofnetwork/thruk/usercontent/backgrounds
Mais pour l'affichage du dashboard il va rechercher dans /srv/eyesofnetwork/thruk/root/thruk/usercontent/backgrounds

En déplaçant à la main les fichiers, ça marche. Je n'ai pas trouvé de fichier de configuration où on pourrait paramétrer ça...plutôt étrange.

Pour les images statiques, plus d'erreur dans les log, mais ça ne marche toujours pas...

Si quelqu'un a une idée.....

Une bonne journée à tous.

Avatar du membre
Seb
Messages : 3543
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Images Utilisateurs - DashBoard Thruk

Message par Seb » 12 mars 2018, 09:30

Peut être mettre en place un lien symbolique pour le répertoire usercontent de thruk/root/usercontent vers thruk/usercontent?
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Répondre