Remontée des machines avec OCS

Répondre
Bedoui
Messages : 25
Enregistré le : 04 août 2017, 13:19

Remontée des machines avec OCS

Message par Bedoui » 17 août 2017, 13:23

Bonjour EyesOfNetwork,

Du retour après un truc d'inventaire n'est pas réalisé correctement.

J’ai installé EyesOfNetwork-5.0 avec comme version de GLPI 0.90.3 , un plugin OCS Inventory NG 1.2.1 installé et activé


sous srv/eyesofnetwork j’ai le dossier ocsinventory-server-2.2

J’ai pâs du fichier sous
/etc/httpd/conf.d/z-ocsinventory-server.conf mais lacées à la base de donnés s'effectue parfaitement vu que j'ai configuré
/etc/httpd/conf.d/ocsinventory-server.conf du coup sous

Outils\OCS Inventory NG\Configuration du serveur OCSNG le test de la base données s'effectue parfaitement


Connexion à la base de données
Connexion à la base de données réussie
Version et Configuration OCSNG valide


passons maintenant coté base de donnés ,
En connectons avec le user ocs j'ai comme base de donnés ocsweb ayant 100 tables
et si je connecte avec l'user root j'aurai comme base de donnés cacti,eonweb,ged,lilac mysql, nagiossb ,notfier ,
ocsweb et glpi qui contient 326 tables
J’ai installé l’agent OCSNG-Windows-Agent-2.0.5 sur une machine client
En indiquant comme serveur d’url http://@ip/ocsinventory(@ip :adresse du serveur EyesOfNetwork)
à titre d’info la réponse sur cette url à travers le navigateur est :
Bad Request
Your browser sent a request that this server could not understand.


Bref l’inventaire ne s’effectue pas coté ocs ni par accès par ceci https://@ip/ocsreports/ ,ni coté base de donnés

J’ai fais attention concernant le profil de 'l’utilisateur connecté super admin pour qu'il aura l'accès nécessaire pour le parc.
Merci de me guider si j'ai oublié un truc à paramétrer .

Avatar du membre
Seb
Messages : 3430
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Remontée des machines avec OCS

Message par Seb » 17 août 2017, 15:28

Dejà abordé, un petit coup de fonction recherche ;)
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Bedoui
Messages : 25
Enregistré le : 04 août 2017, 13:19

Re: Remontée des machines avec OCS

Message par Bedoui » 22 août 2017, 16:03

Bonjour Seb ,

Oui je confirme comme mentionné dans le forum , le fait d' ignorer https en modifiant l’attribut RewriteEngine dans le fichier eon.conf sous etc/httpd/conf.d ,
ainsi que l'installation d'un agent plus récent et plus compatible que la version du serveur OCS 2.2 ,OCSNG-Windows-Agent-2.2Beta en indiquant la version de serveur en http , les machines de test sont bien remontées .

Reste à confirmer avec vous l'impact d'une migration vers la version d'OCS 2.3 ainsi que l'impact d'ignorer le SSL.

Répondre