Erreur YUM

Problèmes rencontrés lors de l'utilisation d'EyesOfNetwork
Caro_mrt
Messages : 37
Inscription : 14 janvier 2016, 10:23

Erreur YUM

Message par Caro_mrt » 03 février 2016, 14:09

Bonjour,
depuis mon serveur EyesOfNetwork, je n'arrive pas à effectuer d'installation.
Par exemple, lorsque j'entre la commande suivante :
yum install perl
J'obtiens cette réponse :
Modules complémentaires chargés : fastestmirror
Configuration du processus d'installation
Loading mirror speeds from cached hostfile
Erreur : Cannot retrieve metalink for repository: epel. Please verify its path and try again

J'ai déjà trouvé les autres messages sur le forum à ce sujet, mais j'ai réalisé toutes les manipulations et aucune n'a marché :(
Voici le contenu de mon fichier yum.conf :
[main]
cachedir=/var/cache/yum
persistdir=/var/cache/yum/$basearch/$releasever
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
installonly_limit=5
bugtracker_url=http://bugs.centos.org/set_project.php? ... tegory=yum
distroverpkg=centos-release

Merci de votre aide !

Avatar de l’utilisateur
Seb
Messages : 3482
Inscription : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Erreur YUM

Message par Seb » 03 février 2016, 14:28

Bonjour, vous êtes en quelle version eon?
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Caro_mrt
Messages : 37
Inscription : 14 janvier 2016, 10:23

Re: Erreur YUM

Message par Caro_mrt » 03 février 2016, 15:46

Lorsque j'effectue:
cat /etc/redhat-release
J''obtiens la réponse suivante:
EyesOfNetwork release 4.2 (Florian)

Avatar de l’utilisateur
Seb
Messages : 3482
Inscription : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Erreur YUM

Message par Seb » 03 février 2016, 20:00

En même temps votre erreur porte sur un repo epel...il est configuré????
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Caro_mrt
Messages : 37
Inscription : 14 janvier 2016, 10:23

Re: Erreur YUM

Message par Caro_mrt » 04 février 2016, 09:35

Oui, il est configuré, j'ai cherché sur beaucoup de forum, mais maintenant lorsque j'effectue un téléchargement j'obtiens la réponse suivante :

Configuration du processus d'installation
http://vault.centos.org/%24releasever/o ... repomd.xml: [Errno 12] Timeout on http://vault.centos.org/%24releasever/o ... repomd.xml: (28, 'connect() timed out!')
Essai d'un autre miroir.
Erreur : Cannot retrieve repository metadata (repomd.xml) for repository: base. Please verify its path and try again

j'ai déjà essayé beaucoup de manip mais rien ne fonctionne, en fait j'ai besoin d'installer perl, perl-net-ip et perl-net dns j'ai essayé avec des rpm mais il manque toujours des modules nécessaires, y a t'il un autre moyen d'installer sans passer par yum?

Avatar de l’utilisateur
Seb
Messages : 3482
Inscription : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Erreur YUM

Message par Seb » 04 février 2016, 10:08

Perl est déjà présent dans eon donc il vous manque juste perl-Net-IP-1.25-13.el6.noarch.rpm et perl-Net-DNS-0.65-4.el6.x86_64.rpm... Cherchez les sur le net, copiez les sur eon puis un "rpm -ivh nomrpm" et hop :)
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Caro_mrt
Messages : 37
Inscription : 14 janvier 2016, 10:23

Re: Erreur YUM

Message par Caro_mrt » 04 février 2016, 14:52

Merci beaucoup de votre aide mais j'avais déjà essayé, et lorsque j'effectue cette commande j'obtiens la réponse suivante :

[root@eon ~]# rpm -ivh perl-Net-IP-1.25-13.el6.noarch\(1\).rpm
attention: perl-Net-IP-1.25-13.el6.noarch(1).rpm: Entête V4 DSA/SHA1 Signature, key ID 192a7d7d: NOKEY
erreur: Dépendances requises:
/usr/bin/perl est nécessaire pour perl-Net-IP-1.25-13.el6.noarch
perl(:MODULE_COMPAT_5.10.1) est nécessaire pour perl-Net-IP-1.25-13.el6.noarch
perl(Exporter) est nécessaire pour perl-Net-IP-1.25-13.el6.noarch
perl(Getopt::Std) est nécessaire pour perl-Net-IP-1.25-13.el6.noarch
perl(Math::BigInt) est nécessaire pour perl-Net-IP-1.25-13.el6.noarch
perl(strict) est nécessaire pour perl-Net-IP-1.25-13.el6.noarch
perl(vars) est nécessaire pour perl-Net-IP-1.25-13.el6.noarch
[root@eon ~]#

Caro_mrt
Messages : 37
Inscription : 14 janvier 2016, 10:23

Re: Erreur YUM

Message par Caro_mrt » 04 février 2016, 14:54

C'est que j'ai besoin de superviser le trafic pour Nagvis et Weathermap, si vous avez un moyen de contourner le problème, je suis prenante !

Avatar de l’utilisateur
Seb
Messages : 3482
Inscription : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: Erreur YUM

Message par Seb » 05 février 2016, 06:47

ça m'étonne pour perl, vous avez fait un update avant ou un truc du genre?
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

Caro_mrt
Messages : 37
Inscription : 14 janvier 2016, 10:23

Re: Erreur YUM

Message par Caro_mrt » 05 février 2016, 09:09

Justement, lorsque j'effectue un update j'obtiens la même réponse.. :?

Répondre