Mise à jour 5.0 : export ne se fait plus

Problèmes rencontrés lors de l'installation d'EyesOfNetwork
Répondre
Laurent Chevrier
Messages : 45
Enregistré le : 19 décembre 2016, 12:03

Mise à jour 5.0 : export ne se fait plus

Message par Laurent Chevrier » 26 janvier 2017, 17:24

Bonjour,

J'ai créé une nouvelle VM en version 5.0. J'ai suivi le process de migration depuis une 4.1, j'ai un peu galérer mais çà s'est passé correctement.

J'ai lancé l'export, il a généré 15 lignes de log et il bloque sur "NagiosContactExporter attempting to export contact configuration." depuis plus de 2 heures.
Est ce quelqu'un peut me dire d'où vient le problème ?

Merci d'avance
Laurent

Avatar du membre
Akecc
Messages : 146
Enregistré le : 19 avril 2016, 16:24
Localisation : Saint-Brieuc

Re: Mise à jour 5.0 : export ne se fait plus

Message par Akecc » 27 janvier 2017, 09:40

Bonjour,

1. Décompressez le répertoire « srveon-srv.xxx.master.tar.gz ».
Un répertoire « srv » est créé.
2. Coupez le service « nagios »
Service nagios stop
3. Si vous avez ajouté des plug-ins dans votre ancienne version, il faut les copier dans la nouvelle version
Avec un logiciel comme WinSCP ou filezilla, télécharger le dossier /srv/eyesofnetwork/nagios/plugins puis le déplacer au même endroit sur le nouveau serveur.
4. Décompresser le fichier sql « srveon-lilac.xxxx.sql.bz2 »
Ouvrir le fichier sql avec un éditeur de texte : Supprimer tout le début jusqu’à la table « nagios_command », de la fin jusqu’à la table « nagios_template_service_inheritance ».
Supprimer également les deux tables « nagios_main_configuration » qui sont au milieu du fichier.
5. Importer le fichier dans la BDD de « lilac »
mysql lilac -u root --password=root66 < /srv/save/lilac.sql
6. Redémarrer le service « nagios »
Service nagios restart
Ouvrir l’interface web du serveur https://MonServeurEON/, aller dans Administration, Configuration nagios, Nagios Daemon Configuration, other. Faire une copie d’écran.
7. Appliquer la configuration
Toujours sur l’interface : Administration, Appliquer la configuration, exporter.


Ton problème vient sans doute des BDD sql. Réinjecte ta base de donnée d'origine :
mysql lilac -u root --password=root66 < /srv/eyesofnetworkconf/lilac/lilac.sql

Puis recommence à partir du point 4 ! J'ai également eu ce soucis si ça peut te rassurer.

Bon courage ;)
"C'est Darwin, tu t'adaptes ou tu dégages" :twisted:

Laurent Chevrier
Messages : 45
Enregistré le : 19 décembre 2016, 12:03

Re: Mise à jour 5.0 : export ne se fait plus

Message par Laurent Chevrier » 27 janvier 2017, 09:52

j'ai déjà fait çà à plusieurs reprise, remettre le sql de base de lilac, épurer l'export de mon ancienne version pour le réinjecter...
Avec le sql de base de lilac, l'export ne pose pas de soucis.

Est ce qu'il faut conserver la re-création des tables dans le sql lilac ?

Laurent Chevrier
Messages : 45
Enregistré le : 19 décembre 2016, 12:03

Re: Mise à jour 5.0 : export ne se fait plus

Message par Laurent Chevrier » 27 janvier 2017, 14:23

J'ai refait et cette fois ci l'export va plus loin... mais ne se termine toujours pas correctement... :evil:

J'ai 5 erreurs et 2067 warnings du type :

Warning: Host 'SE:CMP_SaintPourcainSurSiouleEnfant switch' has no default contacts or contactgroups defined!
Warning: Host 'SE:CMP_SaintPourcainSurSiouleEnfant switch' has no services associated with it!

Warning: Service 'memory' on host 'MY:VMWindows:Wocs1' has no check time period defined!
Warning: Service 'uptime_host' on host 'MY:VMWindows:Winrestapp' has no check time period defined!

Error: The name of host 'MY:FIREWALL (secondary)' contains one or more illegal characters.
Error: The name of host 'MY:Switch 2MTL (PMTL 2ème étage)' contains one or more illegal characters.

Pour les erreurs, j'ai virer les parenthèses dans les noms et celà m'a aussi supprimé les warning et tout fonctionne.

Merci pour votre aide

Répondre