AutoDiscovery Job Not Completing Successfully...

Répondre
aman.9994
Messages : 3
Enregistré le : 31 octobre 2018, 13:37

AutoDiscovery Job Not Completing Successfully...

Message par aman.9994 » 22 novembre 2018, 13:39

Dear Administrators, :P

I got stuck at autodiscovery job at eon web.

here are logs given below for reference.

=============================================================================================================================================
AutoDiscovery
Job Name: discover ucn
Disocvery 2

Start Time:
Elapsed Time: 0 Hours 9 Minutes 12 Seconds
Current Status: Failed
Restart Job | Remove Job | Return To AutoDiscovery Menu
Time
Type

Text
2018-11-22 13:30:38

ERROR

Engine autodiscovery process failed to complete successfully.
2018-11-22 13:30:38

ERROR

Nmap failed to complete successfully. Could be permissions issue (check sudo access). Aborting discovery.
2018-11-22 13:30:13

NOTICE

NMAP: NSE Timing: About 31.36% done; ETC: 18:01 (0:01:08 remaining)
2018-11-22 13:29:42

======================================================================================================================================


I had check permissions of /usr/bin/nmap which is given below.

[root@eon tmp]# ll /usr/bin/nmap
-rwxrwxrwx. 1 root root 2647536 Apr 11 2018 /usr/bin/nmap
[root@eon tmp]#
[root@eon tmp]#

Is there any extra permissions required to assign.

Please suggest me guys.


Thanks
Aman :D

Avatar du membre
Seb
Messages : 3543
Enregistré le : 11 février 2009, 17:35
Localisation : Limoges
Contact :

Re: AutoDiscovery Job Not Completing Successfully...

Message par Seb » 30 novembre 2018, 12:54

Think u need to adjust sudoers for user pache/nagios to /bin/nmap ;)
"Mieux vaut cent chevaux sous une selle que d'un âne assis dessus"
Joe dans son bar servant un de ses clients...JBT

aman.9994
Messages : 3
Enregistré le : 31 octobre 2018, 13:37

Re: AutoDiscovery Job Not Completing Successfully...

Message par aman.9994 » 05 décembre 2018, 12:41

Hi Seb,

Thanks for the reply, can you elobarate little bit more.

i have below sudores file which line need to correct.
=====================================================================================================================================================
Defaults env_keep += "MAIL PS1 PS2 QTDIR USERNAME LANG LC_ADDRESS LC_CTYPE"
Defaults env_keep += "LC_COLLATE LC_IDENTIFICATION LC_MEASUREMENT LC_MESSAGES"
Defaults env_keep += "LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER LC_TELEPHONE"
Defaults env_keep += "LC_TIME LC_ALL LANGUAGE LINGUAS _XKB_CHARSET XAUTHORITY"

#
# Adding HOME to env_keep may enable a user to run unrestricted
# commands via sudo.
#
# Defaults env_keep += "HOME"

Defaults secure_path = /sbin:/bin:/usr/sbin:/usr/bin

## Next comes the main part: which users can run what software on
## which machines (the sudoers file can be shared between multiple
## systems).
## Syntax:
##
## user MACHINE=COMMANDS
##
## The COMMANDS section may have other options added to it.
##
## Allow root to run any commands anywhere
root ALL=(ALL) ALL

## Allows members of the 'sys' group to run networking, software,
## service management apps and more.
# %sys ALL = NETWORKING, SOFTWARE, SERVICES, STORAGE, DELEGATING, PROCESSES, LOCATE, DRIVERS

## Allows people in group wheel to run all commands
%wheel ALL=(ALL) ALL

## Same thing without a password
# %wheel ALL=(ALL) NOPASSWD: ALL

## Allows members of the users group to mount and unmount the
## cdrom as root
# %users ALL=/sbin/mount /mnt/cdrom, /sbin/umount /mnt/cdrom

## Allows members of the users group to shutdown this system
# %users localhost=/sbin/shutdown -h now

## Read drop-in files from /etc/sudoers.d (the # here does not mean a comment)
#includedir /etc/sudoers.d

# eonweb
apache ALL=NOPASSWD:/bin/systemctl * snmptt,/bin/systemctl * snmptrapd,/bin/systemctl * snmpd,/bin/systemctl * nagios,/bin/systemctl * ged,/usr/bin/nmap
===================================================================================================================================================

Répondre