Erreur export dans "lilac" -> Unable to find timeperiod with id: 14 for host_notification_period

Problèmes rencontrés lors de l'installation d'EyesOfNetwork
Répondre
yoyohand
Messages : 26
Enregistré le : 02 mars 2015, 18:15

Erreur export dans "lilac" -> Unable to find timeperiod with id: 14 for host_notification_period

Message par yoyohand » 25 août 2017, 10:45

Bonjour à tous,

Tout d'abord merci pour ce super logiciel qui s'améliore d'année en année, les documentations s'enrichissent et les mises à jour plus simple à réaliser ;)

Je suis en train de basculer mon EON vers la dernière version (4.2 -> 5.1), après l'import de mon fichier Lilac je rencontre un souci au moment de lancer le job pour l'upgrade de nagios

Voici l'erreur:

"ERROR
Engine export process failed to complete successfully.
2017-08-25 11:31:43

ERROR
Contact Exporter failed export. Bailing out of job...
2017-08-25 11:31:43

ERROR
Unable to find timeperiod with id: 14 for host_notification_period
2017-08-25 11:31:43

NOTICE
NagiosContactExporter attempting to export contact configuration."

J'ai suivi les conseils Akecc et Seb pour modifier mon fichier lilac.sql et ne garder que les tables nécessaires
J'ai eu des messages d'erreurs similaires pour d'autres paramètres, je les aient modifié manuellement dans "Nagios Daemon Configuration" pour mettre les bonnes valeurs mais la je ne trouve pas le champ à renseigner


Merci pour votre aide, bonne journée,
Yoann

yoyohand
Messages : 26
Enregistré le : 02 mars 2015, 18:15

Re: Erreur export dans "lilac" -> Unable to find timeperiod with id: 14 for host_notification_period

Message par yoyohand » 25 août 2017, 15:02

J'ai avancé sur mon problème mais je n'ai pas de solution rapide

En faite j'ai une seule "time_period" dans ma conf qui s'appelle "24x7".
Elle est censée s'appliquer sur l'ensemble de mes équipements, modèles....

Je viens de m'apercevoir qu'elle n'apparait pas sur certains équipements
Pour qu'elle soit visible, il faut que j'édite l'équipement, que je la reselectionne (elle est pourtant déjà sélectionnée) et que j'applique la modification. Après ça, j'ai bien la ligne "Notification Period: 24x7" de visible

J'ai modifié manuellement mes contacts et mes modèles mais j'ai le même souci pour mes équipements
Compte tenu du nombre, je ne veux pas passer sur chaque équipement pour faire cette manip. Comment faire?

Merci,

Avatar du membre
Akecc
Messages : 146
Enregistré le : 19 avril 2016, 16:24
Localisation : Saint-Brieuc

Re: Erreur export dans "lilac" -> Unable to find timeperiod with id: 14 for host_notification_period

Message par Akecc » 01 septembre 2017, 11:03

Salut,

essaie de réappliquer tes modèles peut-être ?
Sinon pour être sûr de l'erreur, quand tu fais ton restart job, passe à la page 2 des erreurs puis reviens à la première page. Tu aura tes erreurs clairement affichées ! ;)
"C'est Darwin, tu t'adaptes ou tu dégages" :twisted:

yoyohand
Messages : 26
Enregistré le : 02 mars 2015, 18:15

Re: Erreur export dans "lilac" -> Unable to find timeperiod with id: 14 for host_notification_period

Message par yoyohand » 11 septembre 2017, 10:51

Bonjour,

Désolé pour la réponse tardive, j'étais en vacances :)
Je vais refaire une tentative de migration dans la semaine, j'ai essayé de réappliquer les modèles ça n'a pas marché

Je risque devoir passer une commande dans la base SQL pour forcer le paramètre sur tous mes équipements plutôt que de passer à la main pour la mettre à jour

yoyohand
Messages : 26
Enregistré le : 02 mars 2015, 18:15

Re: Erreur export dans "lilac" -> Unable to find timeperiod with id: 14 for host_notification_period

Message par yoyohand » 11 septembre 2017, 17:16

Bonjour à tous,

Je reviens sur ce sujet que je n'arrive pas à résoudre!
J'ai tenter de modifier ma base SQL avec PHPMyAdmin avant de la réinjecter, ça n'a pas suffit

J'ai l'impression que c'est un bug
Je vais dans "Equipements" -> "Lister", j'édite n'importe lequel de mes équipements, dans le menu "Check" et le menu "Notifications", respectivement les champs "Check Period" et "Notification Period" ne s'affichent pas.
Pourtant, si je clique sur éditer, je vois que la case "provide value" est cochée pour les 2 champs, je valide sans rien modifier et les valeurs apparaissent et semble être prise en compte

Comment je peux forcer la prise en compte de ces 2 champs pour tout mes équipements?
Je vais tenter l'installation d'une version intermédiaire d'EoN voir si j'ai le même problème

yoyohand
Messages : 26
Enregistré le : 02 mars 2015, 18:15

Re: Erreur export dans "lilac" -> Unable to find timeperiod with id: 14 for host_notification_period

Message par yoyohand » 12 septembre 2017, 10:34

Bonjour,

Je viens de comprendre mon erreur
J'ai suivi ce tuto viewtopic.php?f=6&t=1839 pour éditer mon fichier "lilac.sql" et il ne fallait pas que je supprime la fin de mon fichier SQL il y avait des tables nécessaires à importer pour faire le lien

Par contre après l'import Nagios ne démarre pas, j'ai l'erreur suivante dans les logs:
Sep 12 10:31:26 nagios systemd[1]: Starting Nagios Network Monitoring...
Sep 12 10:31:26 nagios systemd[1]: nagios.service: control process exited, code=exited status=254
Sep 12 10:31:26 nagios systemd[1]: Failed to start Nagios Network Monitoring.
Sep 12 10:31:26 nagios systemd[1]: Unit nagios.service entered failed state.
Sep 12 10:31:26 nagios systemd[1]: nagios.service failed.

Et le status du menu "Exporter":
2017-09-12 10:27:57
ERROR: Engine export process failed to complete successfully.

2017-09-12 10:27:57
ERROR: Restart failed.

2017-09-12 10:27:57
ERROR: Nagios Restart Failed. You need to manually restart Nagios

2017-09-12 10:27:56
NOTICE: NagiosMainExporter complete.

Des idées?
Merci,

yoyohand
Messages : 26
Enregistré le : 02 mars 2015, 18:15

Re: Erreur export dans "lilac" -> Unable to find timeperiod with id: 14 for host_notification_period

Message par yoyohand » 19 septembre 2017, 16:16

Bonjour à tous,

Je reviens sur mon sujet après avoir réussi la migration de mon serveur EON! (ouf enfin!!!)
J'ai eu énormément de problème pour réaliser cette mise à jour, du coup j'ai fais mes propres notes des erreurs à ne pas reproduire en complément de la documentation officielle de mise à jour
Comment je peux faire partager ces infos à la communauté de façon plus visible que dans ce post?

Pour conclure, j'ai résolu mon souci en retirant les tables suivantes:
tables de log (autodiscovery_log_entry; export_log_entry et import_log_entry)
nagios_cgi_configuration
nagios_main_configuration

Toutes les autres tables étaient nécessaires pour que mon nagios redémarre

L'export fonctionne mais j'ai toujours une erreur à la fin pour me demander de redémarrer nagios manuellement.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité